Coding breuchte proxmox hilfe (1 Betrachter)

Status
Es sind keine weiteren Antworten möglich.

Skull³

Community-Team
Teamleitung
Black-Market: 0 / 0 / 0
4 April 2019
6.887
100 %
er hat Problem mit seinem Netzwerk, die VM kann das Internet nicht ansprechen, ich habe aber gerade keine Zeit, da ich noch auf der Arbeit bin. Habe nur mal kurz drueber geschaut, IP Forwarding ist auch nicht aktiv, falls er sich ueberlegen sollte, ein Netzwerk abzuschotten ...
 

Speddy20537

Szene-Pirat
Black-Market: 0 / 0 / 0
18 August 2013
1.162
57 %
Die ip forwarding und alles was mit denn ip sachen zu tun hatt muss mann manuel einfügen mom ich schaue mal ob ich noch das video finde dazu.
 

Skull³

Community-Team
Teamleitung
Black-Market: 0 / 0 / 0
4 April 2019
6.887
100 %
jepp

net.ipv4.ip_forward=1
net.ipv6.conf.all.forwarding=1

echo 1 > /proc/sys/net/ipv4/ip_forward

er muss sich seine IPs noch mal anschauen und ob die Masken richtig gesetzt sind.
 

torty40

Registriert
Black-Market: 0 / 0 / 0
14 Mai 2019
56
8 %
speddy köntest per any oder team uff mir siehste ja wie gesetzt habe und ob das so stimmt
 

Speddy20537

Szene-Pirat
Black-Market: 0 / 0 / 0
18 August 2013
1.162
57 %
Ich bin gerade erst wieder zu hause ich will jetzt erstmal Abend Brot machen und denn ins bett bin hunde müde aber wenn du willst kann ich mir das morgen mal ansehen und denn können wir es zusammen machen über tv.


Ich habe aber gerade gesehen das video was ich suchen wollte hast du ja schon hast du auch die ip umgeändert in deine ip die zu deinen server gehören.
 

torty40

Registriert
Black-Market: 0 / 0 / 0
14 Mai 2019
56
8 %
jop meine config sieht wie folgt aus

auto vmbr0
iface vmbr0 inet static
address 116.202.232.229
netmask 255.255.255.192
bridge_ports none
bridge_stp off
bridge_fd 0
up ip route add 116.202.232.211/32 dev vmbr0
up ip route add 116.202.232.212/32 dev vmbr0
up ip route add 116.202.232.213/32 dev vmbr0
up ip route add 116.202.232.214/32 dev vmbr0
up ip route add 116.202.232.215/32 dev vmbr0


auto vmbr1
iface vmbr1 inet static
address 136.143.242.222
netmask 255.255.255.248
bridge_ports none
bridge_stp off
bridge_fd 0
 

BIOS

Forum-Mitglied
Black-Market: 1 / 0 / 0
20 Dezember 2018
313
31 %
Beispiel config:

Code:
auto eth0
iface eth0 inet static
  address X.Y.Z.16
  netmask 255.255.255.255
  gateway X.Y.Z.1
  pointopoint X.Y.Z.1
  # route X.Y.Z.0/27 via X.Y.Z.1
  # up route add -net X.Y.Z.0 netmask 255.255.255.224 gw X.Y.Z.1 dev eth0

auto vmbr56
iface vmbr56 inet static
    address 172.16.56.1
    netmask 255.255.255.0
    pre-up brctl addbr $IFACE
    post-up route add -host X.Y.Z.56 $IFACE
    post-down brctl delbr $IFACE
  
auto vmbr57
iface vmbr57 inet static
    address 172.16.57.1
    netmask 255.255.255.0
    pre-up brctl addbr $IFACE
    post-up route add -host X.Y.Z.57 $IFACE
    post-down brctl delbr $IFACE
  
  
auto vmbr58
iface vmbr58 inet static
    address 172.16.58.1
    netmask 255.255.255.0
    pre-up brctl addbr $IFACE
    post-up route add -host X.Y.Z.58 $IFACE
    post-down brctl delbr $IFACE
  
  
auto vmbr59
iface vmbr59 inet static
    address 172.16.59.1
    netmask 255.255.255.0
    pre-up brctl addbr $IFACE
    post-up route add -host X.Y.Z.59 $IFACE
    post-down brctl delbr $IFACE
  
  
auto vmbr60
iface vmbr60 inet static
    address 172.16.60.1
    netmask 255.255.255.0
    pre-up brctl addbr $IFACE
    post-up route add -host X.Y.Z.60 $IFACE
    post-down brctl delbr $IFACE
  
  
auto vmbr61
iface vmbr61 inet static
    address 172.16.61.1
    netmask 255.255.255.0
    pre-up brctl addbr $IFACE
    post-up route add -host X.Y.Z.61 $IFACE
    post-down brctl delbr $IFACE
  
  
auto vmbr62
iface vmbr62 inet static
    address 172.16.62.1
    netmask 255.255.255.0
    pre-up brctl addbr $IFACE
    post-up route add -host X.Y.Z.62 $IFACE
    post-down brctl delbr $IFACE
  
  
auto vmbr63
iface vmbr63 inet static
    address 172.16.63.1
    netmask 255.255.255.0
    pre-up brctl addbr $IFACE
    post-up route add -host X.Y.Z.63 $IFACE
    post-down brctl delbr $IFACE
was sagt


Code:
cat /proc/sys/net/ipv4/ip_forward
wenn 0 rauskommt, bitte auf 1 setzen



Code:
 sysctl -w net.ipv4.ip_forward=1
persistent kann man das im /etc/sysctl.conf setzen
 

Invalid

Mr. Dino Kacke
EliTE-Mitglied
Black-Market: 1 / 0 / 0
29 September 2018
138
21 %
jo
auto vmbr0 iface
vmbr0 inet static
address - erste verwendbare IP aus dem SUBNET
netmask 255.255.255.255 / - ebenfalls aus m subnet wenn du mit der maus langsam über eine IP fährst
bridge_ports none
bridge_stp off
bridge_fd 0
up ip route add (Additional-IP)/32 dev vmbr0
die ips aus m subnet anhängen

Meine..
auto vmbr0
iface vmbr0 inet static
address xxxxxxxxx
netmask 255.255.255.xxx
bridge_ports none
bridge_stp off
bridge_fd 0
up ip route add xsxsxsxsxsx/32 dev vmbr0

dann

sysctl -w net.ipv4.ip_forward=1
- für langfristig
/etc/sysctl.d/99-hetzner.conf
/etc/sysctl.conf

net.ipv4.ip_forward=1 einfügen, bzw # entfernen

wichtig
wenn du in Proxmox ne VM anlegst, gateway ist deine haupt-ip
ip eintragen z.b 127.0.0.1/32

ansosten wären logfiles, gut.
 

torty40

Registriert
Black-Market: 0 / 0 / 0
14 Mai 2019
56
8 %
### Hetzner Online GmbH installimage
# sysctl config
#net.ipv4.ip_forward=1
net.ipv4.conf.all.rp_filter=1
net.ipv4.icmp_echo_ignore_broadcasts=1
# ipv6 settings (no autoconfiguration)
net.ipv6.conf.default.autoconf=0
net.ipv6.conf.default.accept_dad=0
net.ipv6.conf.default.accept_ra=0
net.ipv6.conf.default.accept_ra_defrtr=0
net.ipv6.conf.default.accept_ra_rtr_pref=0
net.ipv6.conf.default.accept_ra_pinfo=0
net.ipv6.conf.default.accept_source_route=0
net.ipv6.conf.default.accept_redirects=0
net.ipv6.conf.all.autoconf=0
net.ipv6.conf.all.accept_dad=0
net.ipv6.conf.all.accept_ra=0
net.ipv6.conf.all.accept_ra_defrtr=0
net.ipv6.conf.all.accept_ra_rtr_pref=0
 

Invalid

Mr. Dino Kacke
EliTE-Mitglied
Black-Market: 1 / 0 / 0
29 September 2018
138
21 %
#net.ipv4.ip_forward=1

#

Weg damit.. sollte es immer noch nicht gehen.. Logfiles...................... bitte
 

Invalid

Mr. Dino Kacke
EliTE-Mitglied
Black-Market: 1 / 0 / 0
29 September 2018
138
21 %
Wir nehmen mal an, du bist im Proxmox Manager.. du gehst auf deine VM loggst dich in der Console ein, mit root und password.
gibst dort in deiner VM mal ifconfig ein, und guckst mal was da kommt.
ich gehe stark davon aus, das du ein Routing Problem hast, irgendwas scheinst du einfach Falsch zu machen.
Ich rate dir übrigens, wenn du damit schon probleme hast, es besser sein zu lassen. Sofern ein schon laufendes System auf diesem Server läuft.
 
Status
Es sind keine weiteren Antworten möglich.

Dieses Thema betrachten gerade (Benutzer: 0, Gäste: 1)